Issue with Stock Availability Creation for New Listings

Resolved
Duration: 5h 23mJun 30, 2026

Affected services

Order Routing

Degraded

Global Inventory

Degraded

Timeline

Resolved
16:23Jun 30, 20263h ago

We have resolved the incident and backfilled all affected listings and stock availabilities.

Identified
13:38Jun 30, 20266h ago

The fix is deployed and newly created listings should now also correctly create stock availabilities again.
A migration to backfill the missing availabilities is in preparation and will also be deployed soon.

Identified
12:21Jun 30, 20267h ago

We identified the cause for the problems and are deploying a fix. We will provide new updates as soon as the fix is deployed.

Investigating
11:00Jun 30, 20269h ago

We are currently investigating an issue where Stock Availability is not automatically created for newly created listings. This may lead to incorrect availability displays and undesired routing behavior. Our engineering team is working on a fix and will provide an update by 13:00 UTC+2 at the latest.

Order RoutingGlobal Inventory